Skip to content

How to Fix Broken Server Paths in Dentrix

Have you ever gone to a workstation and tried to run the appointment book and nothing happens. No message, no windows, nothing.

It happens to us more often than it seems like it should, and it’s easy to fix.

90% of the time this happens, it means that Dentrix cannot find its datafiles. Either:

  • The connection to the server is lost and cannot be restore (e.g. the server is offline)
  • The path to the data has changed

For the first problem:

  • Check the server
  • Check the network
  • Check the network connections on both ends and in the middle
  • Simply try to remount the server

For the second problem:

  • Navigate to: C:\Program Files\Dentrix
  • Look for a program called ep.exe
    • It may be called ep.dtx. If it is, rename it to ep.exe
  • Run ep.exe
  • Set the paths to the data

Your appointment book should appear normally.

Note: Dentrix HQ says that they prefer to have network shares be mounted at “Lettered” drives on windows, but for our money the full path (e.g. //SERVER/Dentrix/Data/) works just as well with fewer problems.

Posted in Dentrix.

3 Responses

Stay in touch with the conversation, subscribe to the RSS feed for comments on this post.

  1. Hotbytes says

    Hi. Can someone please help me with this?
    I have Dentrix G-2. It uses the database from the path J: from the server. Every time I click on the “Appointment book” I get an error saying “path not found” or “incorrect file path”. I have tried all of the following:
    1. Checked network cable… is ok
    2. Edited path by ep.exe in the dentrix folder … it doesn’t use the path although shows J:
    3. removed and reinstalled software
    I shut down my server over the weekend. I am hoping this might help it. I am at my wits end with this issue. . I called Dentrix and since I am not subscribed for tech support which is ridiculously priced, and their per call help is $80, which almost always amounts to $400 minimum, they were not very helpful.
    Could someone give me different options I could try? I thought it was a broken server path issue, but I would really appreciate an expert opinion.
    Thank you!

  2. Ryan says

    I have just recently gotten the same problem after I switched a workstation over to a wireless connection. I figured it was the zone alarm firewall blocking the new IP address to the server so I disabled the firewall and antivirus. That did not work. I checked the network path everything looked ok and the network drive is connected. I switched back over to the wired lan connection and I’m still getting the incorrect filepath. All the other computers on the network work fine. I called dentrix tech support and they did not help at all. If anyone can help me fix this problem it would be much appreciated. My email is

  3. Bob Guchee says

    Maybe not the only fix but we have used this many times. Copy the C:\Program Files\Dentrix folder from a working computer. Probably only one file needed but we don’t know which one.